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vConsolidate performance and power on Intel- and AMD-
based servers running Red Hat Enterprise Linux 5.2

Executive summary

Intel® Corporation (Intel) commissioned Principled
Technologies® (PT) to measure power and performance
with Intel's vConsolidate version 2.0 (Profile 3) workload
on quad-processor servers running Red Hat Enterprise
Linux 5.2 using the following processors:

e Intel Xeon® processor X7460
¢ Intel Xeon processor X7350
e AMD® Opteron® processor 8360 SE

The servers were similarly configured with four
processors, 16 4GB DIMMs, and identical PCl-e NICs
and HBAs. Figure 1 shows the vConsolidate results for
all three servers. It provides a comparison for the test
servers with eight vConsolidate work units, consolidation
stack units (CSUs). (See the Workload section and later
sections for more on CSUs.)

KEY FINDINGS

e The Intel Xeon processor X7460-based server

delivered 48.0 percent greater performance
running vConsolidate with eight CSUs than the
AMD Opteron processor 8360 SE-based
server and 38.7 percent greater performance
than the Intel Xeon processor X7350-based
server (see Figure 1).

The Intel Xeon processor X7460-based server
produced 38.5 percent greater performance
per watt with eight CSUs than the AMD
Opteron processor 8360 SE-based server and
47.6 percent greater performance per watt
than the Intel Xeon processor X7350-based
server (see Figure 2).

In this section, we discuss the best results for all servers. For complete details of the performance of each server

at its optimum number of CSUs, see the Test results section.

As Figure 1 illustrates, the Intel Xeon processor X7460-based server delivered 48.0 percent greater performance
running vConsolidate than the AMD Opteron processor 8360 SE-based server, and 38.7 percent greater

performance than the Intel Xeon processor X7350-based server.

As Figure 2 shows, the Intel
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Figure 1: vConsolidate results at eight CSUs for the three servers we tested.
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higher numbers indicating better performance per watt.

We calculated performance per watt by dividing the vConsolidate score for each server by the measured power
when running eight CSUs for a minimum 30-minute interval. We measured power at 208 V on all servers.
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Figure 2: Relative vConsolidate performance/watt results at eight CSUs for the three servers to run one or more CSUs. The
we tested. typical goal is to run enough
CSUs to push the server under test to its maximum capacity by consuming close to 100 percent of the CPU
capacity.

vConsolidate sums the throughput results of each type of work across all CSUs in a test. Then it amalgamates the
combined throughputs of all CSUs to create an overall score for the server under test. See the Test results
section for more information on this process.

vConsolidate uses the following four performance tests:

LoadSim

Microsoft Exchange Server 2003 Load Simulator (LoadSim) is a benchmark that measures a server’s
performance handling email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email
clients. The simulated clients issue requests to an Exchange server to generate an email load. LoadSim
measures both the server’s response time and the number of messages it delivers. LoadSim is available for free
download from www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F8-
0483C7DDEA85&displaylang=en.

SPECjbb2005

SPECjbb2005 is an industry-standard benchmark from the Standard Performance Evaluation Corp. (SPEC) that
measures a server’s Java performance. (Note: SPEC and SPECjbb2005 are trademarks of the Standard
Performance Evaluation Corporation.) SPEC modeled SPECjbb2005 on the three-tier client/server architecture,
with the middle layer as the primary focus. According to SPEC, “Random input selection represents the first (user)
tier. SPECjbb2005 fully implements the middle tier business logic. The third tier is represented by tables of
objects, implemented by Java Collections, rather than a separate database.” For more information about
SPECjbb2005, see www.spec.org/jbb2005/docs/UserGuide.html.

The results we quote here for this workload are not official SPECjbb2005 results because the vConsolidate
workload uses a slightly modified version of the benchmark. These results are not comparable to SPECjbb2005
results on SPEC’s Web site.
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SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysql.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. In the vConsolidate workload, SysBench created a 100,000-row SQL database and executed a batch of
online transaction processing (OLTP) transactions against that data.

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to the server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

vConsolidate profiles
The vConsolidate workload comes with four sets of VM specifications, which it calls profiles. These profiles define
five key factors for each workload VM:
e number of virtual CPUs (vCPUs) the workload should receive
amount of virtual RAM (vMemory) the workload should receive
the operating system (OS) the workload should run
the key application the workload should run
the workload itself

As we noted earlier, vConsolidate refers to a single collection of these five virtual machines as a consolidate stack
unit (CSU). Depending on the type of server and its available resources, you may choose to run one or more
CSUs. The typical goal is to run enough CSUs to push the server under test to its maximum capacity by
consuming close to 100 percent of the CPU capacity. vConsolidate offers four profiles; we tested with Profile 3,
which we detail in Figure 3.

Profile 3
vCPUs vMemory oS Application
WebBench (Web) 2 1.5 GB Linux 32-bit Apache
LoadSim (mail) 1 1.5GB Windows 32-bit Exchange
SysBench (database) 2 1.5GB Linux 64-bit SQL Server
SPECjbb2005 (Java) 2 2.0GB Linux 64-bit BEA JVM
Idle 1 0.4 GB Windows 32-bit NA

Figure 3: The vConsolidate profile we used in our testing.

For further information on vConsolidate, please contact Intel.

Test results
The result for an execution of the vConsolidate workload amalgamates the results of all four of the workloads it
includes. To calculate a final score for a vConsolidate run, we used the following four steps, as vConsolidate
specifies:
1. Benchmark throughput = benchmark’s raw results/benchmark duration (for each of the four benchmarks)
2. Total benchmark throughput = add benchmark throughput for all CSUs in test
3. Normalized throughput = total benchmark throughput/reference system’s benchmark throughput
4. vConsolidate score = geomean (normalized throughput of all four benchmarks)
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The first step in this process uses whatever raw results a benchmark produces, such as number of transactions or
operations, and the benchmark’s duration in seconds. We calculate a benchmark’s duration by subtracting the
start time of the vConsolidate test from its stop time and converting that time to seconds. WebBench is an
exception to this process because it automatically produces a score in requests per second. For this benchmark,
we calculate the average requests per second for the three WebBench mixes that run while the other benchmarks
are running and record this result as its throughput.

The second step is to sum the throughput for a given benchmark across all CSUs. In the one-CSU case, there is
no need for this step. For the two- through eight-CSU tests, we summed the throughput of each individual
benchmark across all CSUs to obtain that benchmark’s final score.

The third step is to normalize the throughput. We use the one-CSU score of one of the systems under test as the
reference system and assign it a normalized score of 1.00. We then divide the summed throughput for a given
type of work by the reference score for that benchmark. This produces the normalized score for that type of work
in this test. In this test, we used as the reference score the one-CSU score on the Intel Xeon processor X7350-
based server. The last step is to take the geometric mean of the normalized throughput for all four benchmarks.

Figure 4 shows the final score (the median of three runs) and CPU utilization of the test servers by number of
CSUs. The CPU utilization percentage is the average over the period the vConsolidate workload ran.

Server AMD Opteron Intel Xeon processor | Intel Xeon processor
processor 8360 SE X7350 X7460

Efu g‘SbS; Score CPU Score CPU Score CPU
1 3.82 27% 3.96 27% 4.07 18%
2 7.31 57% 7.40 56% 7.86 36%
3 9.95 90% 11.10 85% 11.33 56%
4 11.21 100% 12.55 99% 14.70 76%
5 11.91 100% 13.12 100% 17.29 93%
6 12.34 100% 13.65 100% 18.68 99%
7 12.85 100% 13.87 100% 19.36 100%
8 13.14 100% 14.02 100% 19.44 100%

Figure 4. Final score and CPU utilization of test servers, arranged by number of CSUs.

Figure 5 details the power consumption, in watts, of the test servers while idle and during the median eight-CSU

test run.
Server Idle power (watts) Average power (watts)
AMD Opteron processor 8360 SE 524.19 725.45
Intel Xeon processor X7350 569.60 824.91
Intel Xeon processor X7460 544 .91 775.32

Figure 5: Average power usage (in watts) of the test servers while idle and during the median eight-CSU test run. Lower

numbers are better.

Figure 6 shows the eight-CSU test results, by benchmark and CSU, for the AMD Opteron processor 8360 SE-

based server.
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gg’gg (S)E_ts;gg dp;c:;::rsor Java Database Mail Web Final score
CSu 1 7631.85 199.52 15.28 347.49

Csu 2 8018.04 200.60 15.41 348.18

CSuU3 7790.91 199.39 15.41 346.03

CSu 4 7637.90 199.59 15.71 346.84

CSuU 5 7824.31 201.92 11.92 345.50

CSU 6 7769.25 201.12 14.61 347.36

CSu7 7890.49 201.82 14.72 345.90

CSuU 8 7781.79 200.19 15.78 346.65 13.14

Figure 6: vConsolidate eight-CSU median results, by benchmark and CSU, for the AMD Opteron processor 8360 SE-based server.

Higher scores are better.

Figure 7 shows the eight-CSU test results, by benchmark and CSU, for the Intel Xeon processor X7350-based

server.

?;g;gszgggos?zse?r Java Database Mail Web Final score
CSuU 1 10433.06 207.79 14.31 326.13

CSu 2 10264.21 207.47 14.61 325.16

CSuU 3 10341.21 210.51 15.14 318.22

CSu4 10411.27 211.35 12.66 325.45

CSU 5 10498.44 212.24 14.36 320.70

CSU 6 10342.38 211.02 14.10 323.00

CSU7 10544.65 214.27 15.84 314.24

CSuU 8 10732.05 218.96 16.33 318.30 14.02

Figure 7: vConsolidate eight-CSU median results, by benchmark and CSU, for the Intel Xeon processor X7350-based server. Higher

scores are better.

Figure 8 shows the eight-CSU test results, by benchmark and CSU, for the Intel Xeon processor X7460-based

server.

Q?tz:iz)(?b(:;:;osceeriz‘:r Java Database Mail Web Final score
CSuU 1 15424.40 333.84 14.30 541.23

CSu 2 15314.13 335.67 13.95 534.03

CSuU3 15401.70 337.15 14.79 545.63

CSu4 15456.57 337.04 14.16 548.37

CSuU 5 15533.51 334.33 13.08 538.47

CSU 6 15432.18 337.99 12.69 538.09

CSu7 15513.72 335.50 13.62 541.90

CcsSu 8 15507.94 336.43 13.42 541.04 19.44

Figure 8: vConsolidate eight-CSU median results, by benchmark and CSU, for the Intel Xeon processor X7460-based server. Higher

scores are better.

We include complete results for all three runs on the three test systems in Appendix B.

Note: Due to the complexity and number of components the vConsolidate benchmark uses (e.g., network
interfaces, client computers, storage sub-system, configuration of VMs and benchmark components), Intel does
not recommend directly comparing test results from this report with results from other vConsolidate reports.
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Unless the benchmark and its components have identical configurations, results may vary, providing an

inadequate basis for direct comparison.

Test methodology

Figure 9 summarizes some key aspects of the configurations of the three server systems; Appendix A provides

detailed configuration information.

AMD Opteron Intel Xeon Intel Xeon
Server processor 8360 processor processor
SE-based X7350-based X7460-based
server server server
Processor frequency (GHz) 2.50 2.93 2.66
. 2,000 with
Front-side bus frequency (MHz) HyperTransport 1,066 1,066
Number of processor packages 4 4 4
Number of cores per processor package 4 4 6
Number of hardware threads per core 1 1 1
Motherboard PAAXHOROSWS | 57000FC4UR | S7000FCAUR
. NVIDIA nForce
Chipset Pro 2050 Intel ID3600 Intel ID3600
. PC2-5300 FB- PC2-5300 FB-
RAM (64GB in each) PC2-5300 DDR2 DDR2 DDR2

Figure 9: Key aspects of the configurations of the three server systems.

With the following exception we used the default BIOS settings on each server. On the Intel Xeon processor
X7350-based server and Intel Xeon processor X7460-based server we enabled Intel virtualization technology. On
the AMD Opteron processor 8360 SE-based server we set Power Regulator for ProLiant to Static Performance
Mode and enabled both AMD Virtualization and No-Execute Page-Protection.

To be sure we could push the processors of each of the three system configurations to their maximum capacities,
we tested each server with as many vConsolidate CSUs as the server could handle, starting with one CSU, up to
or extremely close to 100 percent processor utilization. The rest of this section details how we set up the servers

and the vConsolidate workload.

Hardware and software the test involved

Software

We used the following software to configure and run the vConsolidate workload:
e Red Hat Enterprise Linux 5.2

Microsoft Windows Server 2003 R2, Enterprise Edition

Linux 32-bit

Linux 64-bit

Apache

Microsoft Exchange Server 2003

Microsoft SQL Server 2005

BEA JRockit 1.6.0_02-b05

WebBench 5.0

Microsoft Exchange Server Load Simulator (LoadSim) 06.05.7775

SPECjbb2005 v1.07
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SysBench v0.4.0
Intel vConsolidate OEM framework package version 1

Hardware
Our test bed consisted of the following hardware:

The server under test

Eight custom-built Intel Desktop Board D915GMH with Intel Pentium 4 3.0GHz w/HT systems, which we
used for all WebBench clients, LoadSim clients, and WebBench controllers (CSU 2 and CSU 3).

One custom-built Intel Server Board D945GTP system, which we used as both the main vConsolidate
controller and the CSU 1 WebBench controller

NETGEAR GS724T, which we set up into two VLANs (one for external network and one for internal
network)

EMC CLARIiiON CX3 storage

Three EMC CX-4PDAE-FD disk enclosures, with 15 x Hitachi HUS151473VLF4EQ 73.4 GB disk drives
each

QLogic SANblade QLE2462 Dual Port 4-Gbps Fibre Channel Host Bus Adapter (HBA) installed in the
server under test

Figure 10 illustrates the test bed.

[ <7’

vConsolidate test bed

CSU #n Combined |IP addresses

Internal network client Server under test
switch (WebBench « External network IP address: 192.168.0.250
\ controller,
WebBench client, |Main controller
and LoadSim « External network IP address: 192.168.0.100
client) « Internal network IP address for each CSU's
LoadSim and WebBench traffic: in form
( Internal network n e 192.168.n1.100, where n is CSU number (e.g.,
@ CSU #1 = 192.168.11.100)
—( External network {4 \

Internal network IP addresses
« Combined client: in form 192.168.n1.110, where n
is CSU # (e.g., CSU #1 = 192.168.11.110)

VM IP addresses
Server under test Mai troll « Mail server VMs: in form 192.168.n1.115, where n
with one active NIC for D ain controfler is CSU # (e.g., CSU #1 = 192.168.11.115)

external network and one « Web server VMs: in form 192.168.n1.215, where n
NIC per CSU for \ is CSU# (e.g., CSU #1 =192.168.11.215)
WebBench and LoadSim « JavaServer1 - n, DBServer1 - n, IdleServer1 —n

traffic (where n is highest CSU#) = DHCP

Figure 10: Our vConsolidate test bed.
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Server installation

Installing
1.  When the server boots, press Enter.
2. Choose Skip, and press Enter.
3. Click Next.
4. Click Next.
5. Choose U.S. English, and click Next.
6. Type in the installation number, and click OK.
7. Select the first drive for installation, and click Next.
8. Click Yes on the warning window.
9. Click Next.
10. Choose Manually for host name, type the name, and click Next.
11. Verify time zone, and click Next.
12. Type the password in Root password and Confirm password, and click Next.
13. Verify that Virtualization and Software Development are the only options checked, and click Next.
14. Remove the disk from the server, and click Reboot.

Setting up
1. Click Forward.
2. Choose Yes, and click Forward.

3. Disable Firewall, and click Forward.

4. Click Yes on the warning window.

5. Disable SELinux, and click Forward.

6. Click Yes on the warning window.

7. Accept defaults, and click Forward.

8. Verify time and date, and click Forward.

9. Choose No, | prefer to register at a later time, and click Forward.

10. Choose No thanks on the popup window.

11. Click Forward.

12. Click Forward without entering user information.

13. Click Continue on the popup window.

14. Click Forward.

15. Click Finish.

16. Click OK to reboot the server.

Editing the file /etc/grub.conf
1. Open the Terminal.
2. Typenano -w /etc/grub.conf
3. Add dom0 mem=4G mem=64G dom0_vcpus pin=false to the end of the Kernel line.
4. Press CTRL+X to exit the file, press Y to save, and press Enter to return to the Terminal screen.

Disabling services
1. Open the Terminal.
2. Type chkconfig auditd off and press Enter.

Adding scripts and ISO images
1. Open the Terminal.
2. Typemkdir /mnt/ftpvol and press Enter.
3. Typemount 10.41.1.215:/ftpvol /mnt/ftpvol and press Enter.
4. Type cd /mnt/ftpvol/vcon2/server scripts and press Enter.
5. Typecp -vr * /root and press Enter.

Setting up the LUNS
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1. Create a partition:
a. Open a Terminal.
b. Type cat /proc/partitions and press Enter.
2. Find the LUN you are looking to run on:
Type fdisk /dev/ (LUN Name)
Type n and press Enter.
Type p and press Enter.
Type 1 and press Enter.
Press Enter.
Press Enter.
g. Type w and press Enter.
3. Format the LUN:
a. Typemkfs.ext3 -L LUN Name /dev/[LUN Name] 1l
4. Mount the LUN:
a. Typemkdir /mnt/lunl
b. Type nano -w /etc/fstab and press Enter.
c. Insert the following at the bottom of the file:

000 Tw

e LABEL=AMD LUN1 /mnt/lunl ext3 defaults 12
e LABEL=AMD LUN2 /mnt/lun2 ext3 defaults 12
e LABEL=AMD LUN3 /mnt/lun3 ext3 defaults 12
e LABEL=AMD LUN4 /mnt/lun4 ext3 defaults 12
(] LABEL=AMD LUN5 /mnt/lunb ext3 defaults 12
e LABEL=AMD LUN6 /mnt/luné ext3 defaults 12
e LABEL=AMD LUN7 /mnt/lun?7 ext3 defaults 12
e LABEL=AMD LUNS8 /mnt/lun8 ext3 defaults 12

Networking
1. Type cd /etc/xen
2. Typenano -w xend-config.sxp, and press Enter to edit the file.
a. Comment out the line (network-script network-bridge) by placing a # symbol at the
beginning of the line.
b. On the next line, add the following text: (network-script 'network-xen-multi-
bridge")
c. Press CTRL+X to exit the file, press Y to save, and press Enter to return to the Terminal screen.
3. Type cd scripts
4. Type nano -w network-xen-multi-bridge and press Enter to edit the file.
5. Edit this script as needed for your configuration. Here is an example:

#!/bin/sh

# network-xen-multi-bridge

# Exit if anything goes wrong.

set -e

# First arg is the operation.

OP=s1
script=/etc/xen/scripts/network-bridge.xen

_cmd: n $@ n

$script $_cmd vifnum=0 bridge=xenbr0 netdev=eths8
$script $ _cmd vifnum=1 bridge=xenbrl netdev=ethO
S$script $ cmd vifnum=2 bridge=xenbr2 netdev=ethl
$script $ _cmd vifnum=3 bridge=xenbr3 netdev=eth2
$script $ cmd vifnum=4 bridge=xenbr4 netdev=eth3
$script $_cmd vifnum=5 bridge=xenbr5 netdev=eth4
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$script $ cmd vifnum=6 bridge=xenbré netdev=eth5
$script $ cmd vifnum=7 bridge=xenbr7 netdev=ethé
$script $ cmd vifnum=8 bridge=xenbr8 netdev=eth?7

6. Restart the server.

To create one vConsolidate CSU, we had to create the five virtual machines that CSU describes:

Mail server

Web server

Java application server
database server

idle server

The following subsections detail how we created and configured each of these VMs.

Installing and configuring the mail server VM

Follow the steps in the earlier Copying the base VMs section using the following VM specifications:

Name: MailServer1

Virtual processors: 1

Virtual memory: 1.5 GB

Virtual disk size: 10 GB

Virtual network: Internal Network (set the IP address to 192.168.11.115 in Windows within the VM)

Creating the virtual machine
We ran the script virt-install mailserver.sh:

#!/bin/sh
VM _DISKSTORE=/mnt/lunl
VM_NAME=MailServerl

mkdir -p $VM_DISKSTORE/$VM NAME/

virt-install \

--hvm \

--name=$VM_NAME \

--vcpus=1 \

--ram=1500 \

--file=$VM DISKSTORE/$VM NAME/$VM NAME.dsk \
--file-size=10 \

--nonsparse \

--network=bridge:xenbr0 \
--cdrom=/store/windows/win2003r2sp2 32bit cdl.iso \
--os-type=windows \

--os-variant=win2k3 \

--vnc

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing the domain controller
1. Select Start>Administrative Tools=>Manage Your Server.
2. Click Add or remove a role.
3. At the Configure Your Server window, click Next.
4. At the Server Role screen, select Domain Controller, and click Next.

Principled Technologies, Inc.: vConsolidate performance and power on Intel- and
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9.

10.
11.
12.
13.

14.

15.
16.
17.
18.
19.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

At the Install or Configure DNS window, select No, and click Next.

At the New Domain Name screen, type a domain name (vcon. com), and click Next.

At the NetBIOS Domain Name screen, enter a NETBIOS domain name (vcon), and click Next.

Click Next through the following screens: Database and Log Folders, Shared System Volume, and
Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the VM, click Restart Now.

After the VM reboots, log in to the system.

At the This Server is Now a Domain Controller window, click Finish.

Installing Internet Information Services 6.0

©COoNO>OR~®LN =

10
11.

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.
Select Internet Information Services (11S), and click Details.

Click NNTP Service and SMTP Service, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.

Installing Exchange Server 2003

Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.

Click the Deploy the first Exchange 2003 Server link.

Click the New Exchange 2003 Installation link.

Click the Run ForestPrep now link.

When the compatibility issue notice appears, click Continue, and check the Don’t display this message
again box.

At the Welcome screen, click Next.

Accept the End User License Agreement, and click Next.

At Component Selection Screen, keep the defaults, and click Next.

Leave the default account information, and click Next.

Installation should start. (This process may take a while to complete.)

. When the installation completes, click Finish.

. Return to the Exchange Server Deployment Tools screen, and click Run DomainPrep now.
. At the Welcome screen, click Next.

. Accept the End User License Agreement, and click Next.

. At Component Selection Screen, keep the defaults, and click Next.

. At the insecure domain notice, click OK.

. When the installation completes, click Finish.

. Return to the Exchange Server Deployment Tools screen, and click Run Setup Now.

. At the Welcome screen, click Next.

. Accept the End User License Agreement, and click Next.
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20.

21.
22.
23.
24.
25.

26.
27.
28.
29.
30.
31.
32.
33.
34.
35.
36.

At the Component Selection screen, the action for Microsoft Exchange should by default be Typical. (If it
is not, use the drop-down box to set it to Typical.)

Click Next.

For the Installation Type, select Create new Exchange Organization, and click Next.

Enter vcon as the Organization Name, and click Next.

Accept the Microsoft Exchange Server Licensing Agreement, and click Next.

Review the installation summary, and click Next.

The installation should start. (This process may take a while to complete.)

When the installation completes, click Finish.

Close the Exchange Server Deployment Tools window.

Install Microsoft Exchange Server 2003 Service Pack 2.

Insert the SP2 CD, and double-click update exe.

Accept the default location to extract the file, and click OK.

After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
At the Welcome screen, click Next.

Select | agree to accept the License Agreement, and click Next.

At the Component Selection window, leave the default option (Update), and click Next.

Verify the installation Summary, and click Next.

When the installation completes, click Finish.

Add a new 40GB virtual hard disk

L e i e

Shut down the server.

In the VMM right-click the MailServer, and select Details.

Click the Hardware tab in the Details window.

Click Add.

Select Storage Device from the Hardware Type drop-down menu, and click Forward.
Select the radio button beside Simple File, and type
/mnt/lunl/MailServerl/MailServerl data.dsk

Change the file size to 40000.

Select Virtual disk from the Device type drop-down menu, and click Forward.

When the drive is created, power on the MailServer, and log in.

. In the MailServer VM, right-click My Computer, and select Manage.

. In the Computer Management Console, select Disk Management.

. When a Welcome to Initialize and Convert Disk Wizard window appears, click Next.

. Select Disk 1 to initialize.

. At the Select Disk to Convert screen, leave the disk unchecked.

. At the Completing the Initialize and Convert Disk Wizard screen, click Finish.

. Right-click the Disk 1 unallocated box, and select New Partition.

. At the Welcome screen, click Next.

. Leave the partition type as Primary, and click Next.

. Accept the default Partition Size, which should be the same as the Maximum disk space, and click Next.
. Assign the drive letter E, and click Next.

. Format the partition with the NTFS File system, enter Mail Store for the volume label, and click Next.
. At the Completing the New Partition Wizard screen, click Finish.

. The partition should begin formatting.

. When the formatting completes, close the Computer Management console.

. Select Start>All Programs->Microsoft Exchange—> System Manager.

. In the left window pane, expand Servers and MailServer so the First Storage Group is visible.
. Right-click First Storage Group, and select Properties.

. Click Browse, and change the Transaction log and System path location to E:\.

. Check the Enable circular logging box, and click Apply.

. When the pop-up message appears asking if you want to perform this task, click Yes.

. When the message appears saying that all mounted stores are back online, click OK.

. Right-click Mailbox Store under First Storage Group, and select Properties.

. Select the Database tab.

Principled Technologies, Inc.: vConsolidate performance and power on Intel- and

AMD-based servers running Red Hat Enterprise Linux 5.2

12



34.
35.
36.
37.
38.
39.
40.
41.
42.
43.
44.
45.
46.
47.
48.
49.
50.
51.
52.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Mailbox Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Mailbox Store Properties window.

Right-click Public Store under First Storage Group, and select Properties.

Select the Database tab.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Public Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Public Store Properties window.

Reboot the virtual machine.

Installing and configuring the Web server VM
Create a VM using the following VM specifications:

Name: WebServer1 (use WebServer for the Host Name in the VM)

Virtual processors: 2

Virtual memory: 1.5 GB

Virtual Disk Size: 10GB

Virtual Network: Internal Network (set the IP address to 192.168.11.215 within the VM)

Creating the virtual machine
We ran the script virt-install webserver.sh:

To finish setting up this VM for vConsolidate, we had to install several additional software components. The

#!/bin/sh
VM_DISKSTORE=/mnt/1unl
VM_NAME=WebServerl

mkdir -p $VM DISKSTORE/$VM NAME/

virt-install \
--paravirt \
--name=$VM_NAME \
--vcpus=2 \
--ram=1500 \
--file=$VM DISKSTORE/$VM NAME/$VM NAME.dsk \
--file-size=10 \
--nonsparse \
--network=network:default \
--location=nfs:192.168.122.1:/store/linux/rhel52/1386 \
--os-type=linux \
--os-variant=rhel5 \
--vnc

following subsections detail the necessary installation processes.

Install Red Hat Linux
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1. Copy the files from your Linux install CD to a directory on your server. In this example we used
/store/linux/rhel52/i386
2. You need to setup an FTP, HTTP, or NFS server for host the install files for paravirtualized Linux clients.
To use NFS add the following line to /etc/exports:/store * (ro)
3. Then run the following commands to start the NFS server:
e chkconfig nfs on
e service nfs start
4. Atthe Choose a Language screen, select English and press Enter.
5. At the Keyboard Type screen select us, and press Enter.
6. Atthe Configure TCP/IP screen, deselect Enable IPv6. Use the down arrow key to highlight OK, and
press Enter.
7. Use the down arrow key to highlight OK, and press Enter.
8. Atthe Red Hat Enterprise Linux 5, click Next.
9. At the Installation Number popup, select the radio button beside Skip entering Installation Number, and
click OK.
10. At the Skip screen, click Skip.
11. At the Warning popup, select Yes.
12. At the Installation requires partitioning screen, click Next.
13. If a warning appears, click Yes.
14. At the Network Devices screen, set the hostname to webserver1.vcon.lan, and click Next. If you receive
any warnings, click Continue.
15. At the Time zone selection screen, select the appropriate time zone, and click Next.
16. Type password in the root password and confirm fields, and click Next.
17. At the default installation screen, select both Software Development and Web Server, and click Next.
18. When prompted, click Next.
19. At the Congratulations screen, click Reboot.
20. After the system reboots and the Welcome screen appears, click Forward.
21. Agree to the EULA, and click Forward.
22. At the Firewall screen, select Disabled from the Firewall drop-down menu, and click Forward.
23. If a warning popup appears, click Yes.
24. At the SELinux screen, select Disabled from the SELinux Setting drop-down menu, and click Forward.
25. If a warning appears, click Yes.
26. At the Date and Time screen, set the time and date, and click Forward.
27. At the Set Up Software Updates screen, select No, | prefer to register at a later time, and click Forward.
28. If a popup appears asking if you are sure, click No thanks.
29. At the Finish Updates Setup, click Forward.
30. At the Create User Screen, click Forward.
31. If a warning appears, click Continue.
32. At the Sound Card screen, click Forward.
33. At the Additional CDs screen, click Finish.
34. At the popup, click OK.
35. At the logon screen, enter root for the User and password for the password, and press Enter.
36. Open a terminal.
37. Run the following commands:
a. chkconfig auditd off
b. chkconfig smartd off

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Configuring Apache
1. Open a terminal.
2. Type the following
a. nano -w /etc/httpd/conf/httpd.conf
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press Crtl+W to search for LogLevel
Edit LogLevel from warn to crit
Add # infrontof CustomLog logs/access_log common
Press Crtl+X.
Type Y and press Enter to save and close the editor.
nano -w /etc/httpd/conf.d/ssl.conf
Press Crtl+W to search for LogLevel
Edit LogLevel from warn to crit
Add # infront of TransferLog logs/ssl access log
Add # in front of CustomLog logs/ssl request log and in front of the line below it.
Press Crtl+X.
. Type Y and press Enter to save and close the editor.
Type the following commands:
i. chkconfig httpd on
ii. service httpd start

S3TXAT T S@,0 00

WebBench installation
1. Copy the WebBench files:
mkdir /mnt/ftpvol
mount 10.41.1.215:/ftpvol /mnt/ftpvol
cd /mnt/ftpvol/vcon2/
cp wbtree.tar.gz /var/www/html/
cd /var/www/html
tar -zxvf wbtree.tar.gz
cp wbtree/simecgi.c /var/cgi-bin/
cd /var/www/cgi-bin/
cc simcgi.c -o simcgi.exe

T T@ ™m0 00T

Configuring WebServer
1. Go to System - Administration > Network.
2. In the Network Configuration window, in the Devices tab, click Edit.
3. Inthe Ethernet Device window, select the radio button beside Statically set IP addresses, and add the
following:
e Address: 192.168.11.215
e Subnet mask: 255.255.255.0
4. Press Alt+O.
5. Click File>Save. When prompted, click OK.
6. Click File=>Quit.
7. Shut down the server.

On the XEN host complete the following steps:

1. Open a terminal.

2. Type the following commands:
a. virsh dumpxml WebServerl > Webserverl.xml
b. nano -w WebServerl.xml

3. Inthe screen that appears, replace virbr0 with xenbril

4. Press Ctri+X.

5. Type Y and press Enter.

6. Type virsh define WebServerl.xml

7. Start the WebServer, and log on.

Installing and configuring the Java application server VM
Create a VM using the following VM specifications:
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Name: JavaServer1

Virtual processors: 2

Virtual memory: 2 GB

Virtual Disk Size: 10 GB

Virtual Network: External Network (keep the default network DHCP settings)

Creating the virtual machine
We ran the script virt-install webserver.sh:

#!/bin/sh
VM DISKSTORE=/mnt/lunl
VM_NAME=JavaServerl

mkdir -p $VM_DISKSTORE/$VM NAME/

virt-install \
--paravirt \
--name=$VM_NAME \
--vecpus=2 \
--ram=2000 \
--file=$VM DISKSTORE/$VM NAME/$VM NAME.dsk \
--file-size=10 \
--nonsparse \
- -network=network:default \
--location=nfs:192.168.122.1:/store/linux/rhel52/x86 64 \
--os-type=linux \
--os-variant=rhel5 \
--vnc

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

1. Copy the files from your Linux install CD to a directory on your server. In this example we used
/store/linux/rhel52/1386

2. You need to setup an FTP, HTTP, or NFS server for host the install files for paravirtualized Linux clients.

3. To use NFS add the following line to /etc/exports:/store * (ro)

4. Then run the following commands to start the NFS server:

a. chkconfig nfs on
b. service nfs start

5. At the Choose a Language screen, select English, and press Enter.

6. Atthe Keyboard Type screen, select us, and press Enter.

7. At the Configure TCP/IP screen, deselect Enable IPv6. Use the down arrow key to highlight OK, and
press Enter.

8. Use the down arrow key to highlight OK, and press Enter.

9. At the Red Hat Enterprise Linux 5, click Next.

10. At the Installation Number pop up select the radio button beside Skip entering Installation Number, and
click OK.

11. At the Skip screen, click Skip.

12. At the Warning popup, select Yes.

13. At the Installation requires partitioning screen, click Next.

14. If a warning appears, click Yes.

15. At the Network Devices screen, set the hostname to JavaServer1.vcon.lan, and click Next. If you receive
any errors, click Continue.

16. At the Time zone selection screen, select the appropriate time zone, and click Next.
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17.
18.
19.
20.
21.
22.
23.
24.
25.
. If a warning appears, click Yes.
27.
28.
29.
30.
31.
32.
33.
34.
35.
36.
37.
38.

Type password in the root password and confirm fields, and click Next.

At the default installation screen, select both Software Development and Web Server, and click Next.
When prompted, click Next.

At the Congratulations screen, click Reboot.

After the system reboots and the Welcome screen appears, click Forward.

Agree to the EULA, and click Forward.

At the Firewall screen, select Disabled from the Firewall drop-down menu, and click Forward.

If a warning popup appears, click Yes.

At the SELinux screen, select Disabled from the SELinux Setting drop-down menu, and click Forward.

At the Date and Time screen, set the time and date, and click Forward.
At the Set Up Software Updates screen, select No, | prefer to register at a later time, and click Forward.
If a popup appears asking if you are sure, click No thanks.
At the Finish Updates Setup, click Forward.
At the Create User Screen, click Forward.
If a warning appears, click Continue.
At the Sound Card screen, click Forward.
At the Additional CDs screen, click Finish.
At the popup, click OK.
At the logon screen, enter root for the User and password for the password, and press Enter.
Open a terminal.
Run the following commands:
e chkconfig auditd off
e chkconfig smartd off

Statically set IP address

1.
2.
3.

NGO A

Go to System > Administration > Network.
In the Network Configuration window, in the Devices tab, click Edit.
In the Ethernet Device window, select the radio button beside Statically set IP addresses, and add the
following:
a. Address: 192.168.0.41
b. Subnet mask: 255.255.255.0
Press Alt+0.
Click File>Save.
When prompted, click OK.
Click File=>Quit.
Shut down the server.

Installing SPECjbb2005

1.

Copy the SPECjbb2005 files:

mkdir /mnt/ftpvol

mount 10.41.1.215:/ftpvol /mnt/ftpvol

cd /mnt/ftpvol/vcon2/

cp daemon /root/

cp jrockit-jdkl.6.0 03-linux x86 64.tar.gz /root/
cp -r vSpecdBB2005/ /root/

cd /root/

tar -zxvf jrockit-jdkl.6.0_03-linux x86_ 64.tar.gz
nano -w vSpecdBB2005/run.sh

Make sure that the jrockit path is jrockit-jdk1.6.0 03

Press Crtl+X.

Type Y and press Enter to save and close the editor.

Chmod +x vSpecJdBB2005/run.sh

mART T S@m0 o000
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p.

g.

r.

dos2unix vSpecJBB2005/run.sh
nano -w /etc/rc.local
Add the following to the end of the document:
i. /root/daemon > /root/daemon.log &
Press Crtl+X.
Type Y and press Enter to save and close the editor.

On the XEN host complete the following steps:
1. Open a terminal.
2. Type the following commands:

a.
b.
In the screen that appears, replace virbr0 with xenbr0
Press Ctrl+X.
Type Y and press Enter.
Type virsh define JavaServerl.xml
Start the JavaServer, and log on.

No ok

virsh dumpxml JavaServerl > Javaserverl.xml
nano -w WebServerl.xml

Installing and configuring the database server VM
Create VM section using the following VM specifications.

Name: DBServer1

Virtual processors: 2

Virtual memory: 1.5 GB

Virtual disk size: 10 GB

Virtual network: External Network (keep the default network DHCP settings)

Creating the virtual machine
We ran the script virt-install webserver.sh:

#!/bin/sh
VM_DISKSTORE=/mnt/lunl
VM_NAME=DatabaseServerl

mkdir -p $VM_DISKSTORE/$VM NAME/

virt-install \

--paravirt \

--name=$VM NAME \

--vecpus=2 \

--ram=1500 \

--file=$VM DISKSTORE/$VM NAME/$VM NAME.dsk \
--file-size=10 \

--nonsparse \

- -network=network:default \
--location=nfs:192.168.122.1:/store/linux/rhel52/x86 64 \
--os-type=linux \

--os-variant=rhel5 \

--vnc

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

1. Copy the files from your Linux install CD to a directory on your server. In this example we used
/store/linux/rhel52/i386
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10.
11.
12.
13.
14.

15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
20.
30.
31.
32.
33.
34.
35.
36.
37.

You need to set up an FTP, HTTP, or NFS server for host the install files for paravirtualized Linux clients.
To use NFS add the following line to “/etc/exports” : /store * (ro)
Then run the following commands to start the NFS server:
chkconfig nfs on?service nfs start
At the Choose a Language screen, select English and press Enter.
At the Keyboard Type screen, select us, and press Enter.
At the Configure TCP/IP screen deselect Enable IPv6. Use the down arrow key to highlight OK, and press
Enter.
Use the down arrow key to highlight OK, and press Enter.
At the Red Hat Enterprise Linux 5, click Next.
At the Installation Number pop-up window, select the radio button beside Skip entering Installation
Number, and click OK.
At the Skip screen, click Skip.
At the Warning pop-up window, select Yes.
At the Installation requires partitioning screen, click Next.
If a warning appears, click Yes.
At the Network Devices screen, set the hostname to: DBserver1.vcon.lan, and click Next. If you receive
any errors, click Continue.
At the Time zone selection screen, select the appropriate time zone, and click Next.
Type password in the root password and confirm spaces, and click Next.
At the default installation screen, select both Software Development and Web Server, and click Next.
When prompted, click Next.
At the Congratulations screen, click Reboot.
When the system reboots, click Forward at the Welcome screen.
Agree to the EULA, and click Forward.
At the Firewall screen, select Disabled from the Firewall drop-down menu, and click Forward.
If a warning popup appears, click Yes.
At the SELinux screen, select Disabled from the SELinux Setting drop-down menu, and click Forward.
If a warning appears, click Yes.
At the Date and Time screen, set the time and date, and click Forward.
At the Set Up Software Updates screen, select No, | prefer to register at a later time, and click Forward.
If a pop-up window appears asking if you are sure, click No thanks.
At the Finish Updates Setup screen, click Forward.
At the Create User screen, click Forward.
If a warning appears, click Continue.
At the Sound Card screen, click Forward.
At the Additional CDs screen, click Finish.
At the pop-up window, click OK.
At the logon screen, type root for the User and password for the password, and press Enter.
Open a terminal.
Run the following commands:
a. chkconfig auditd off
b. chkconfig smartd off

Statically set IP address

1.

Go to System > Administration > Network.

2. In the Network Configuration window, in the Devices tab, click Edit.

3. Inthe Ethernet Device window, select the radio button beside Statically set IP addresses, and add the
following:
e Address: 192.168.0.21
e Subnet mask: 255.255.255.0

4. Press Alt+O.

5. Click File>Save. When prompted, click OK.

6. Click File=>Quit.
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7. Shut down the server.

Adding an additional hard drive
Shut down the server.
In the VMM right-click the Database Server, and select Details.
Click the Hardware tab in the Details window.
Click Add.
Select Storage Device from the Hardware Type drop-down menu, and click Forward.
Select the radio button beside Simple File, and type
/mnt/lunl/DatabaseServerl/DatabaseServerl data.dsk
7. Change the file size to 25600.
8. Select Virtual disk from the Device type drop-down menu, and click Forward.
9. When the drive is created, power on the Database server, and log in.
10. Open a terminal and run the following command: £disk /dev/xvdb
11. To create a new partition, type n and press Enter.
12. To create a primary partition, type p and press Enter.
13. To number the partition, type 1.
14. For the first cylinder default, press Enter.
15. For size, type: +5120M and press Enter.
16. Create a new partition type n and press Enter.
17. Primary partition, type p and press Enter.
18. Number the partition, type 2 and press Enter.
19. For the first cylinder default, press Enter.
20. For size, press Enter.
21. Type w and press Enter.
22. Type mkfs.ext3 -L logs /dev/xvdbl and press Enter.
23. Type mkfs.ext3 -L data /dev/xvdb2 and press Enter.
24. Type mkdir -p /home/mysqgl/logs
25. Type mkdir -p /home/mysqgl/data
26. Type nano -w /etc/fstab
This opens a nano text editor.
27. Make the following additions at the end of the document:
e LABEL=logs /home/mysgl/logs ext3 defaults 1
e LABEL=logs /home/mysqgl/data ext3 defaults 1
28. Press Cril+X.
29. Type y and press Enter. You have now exited and saved the edited document.
30. Type mount /home/mysqgl/logs
31. Type mount /home/mysqgl/data

L e e

Copy the SPECjbb2005 files

mkdir /mnt/ftpvol

mount 10.41.1.215:/ftpvol /mnt/ftpvol
cd /mnt/ftpvol/vcon2/

cp daemon /root/

cd sysbench/

cp sysbench /root/

cp start mysgl.sh /root/

cp prepare sysbench.sh /root/

cp run.sh /root/

10 cd /mnt/ftpvol/rhel52/x86 64/Server/
11. rpm -ivh perl-DBI-*.x86 64.rpm

12. ¢d /mnt/ftpvol/vcon2/mysql/

©oOoNOOhWN =
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13.
14.
15.
16.
17.
18.
19.
20.

21.
22.
23.

24.

rpm -ivh MySQL-*.x86 64.rpm

service mysgl stop

chkconfig mysqgl off

cd /root

chmod +x *.sh

chmod +x sysbench

chmod +x daemon

mysgld --user=root --basedir=/usr --socket=/tmp/mysqgl.sock --skip-grant-

tables --default-table-type=INNODB --innodb _data home dir=/home/mysql/data --

innodb log group home dir=/home/mysgl/logs --innodb log buffer size=64M --
innodb additional mem pool size=32M --innodb flush log at trx commit=0 --
innodb log file size=1G --innodb thread concurrency=1000 --
max_connections=1000 --table cache=4096 -innodb buffer pool size=1G --
innodb flush method=0 DIRECT &

mysgl -S /tmp/mysqgl.sock -e “drop database sbtest”

mysqgl -S /tmp/mysqgl.sock -e “create database sbtest”

./sysbench prepare --test=oltp --mysqgl-table-engine=innodb --oltp-table-
size=100000 --mysqgl-socket=/tmp/mysqgl.sock --mysqgl-user=mysqgl

nano -w /etc/rc.local

Add the following to the end of the document: /root /daemon > /root/daemon.log &

1.
2

Press Crtl+X.
Type Y and press Enter to save and close the editor.

Backing up the database

1.
2
3.
4.

mysgladmin -S /tmp/mysqgl.sock shutdown
mkdir /home/backup

cp -rv /home/mysqgl/* /home/backup/

rm -rvf /home/backup/*/lost+found/

Restoring the database

1.
2
3.
4.

mysgladmin -S /tmp/mysql.sock shutdown
rm -rvf /home/mysql/data/ib*

rm -rvf /home/mysql/logs/ib*

cp -rvf /home/backup/* /home/mysqgl/

Installing and configuring the idle server VM
Create VM using the following specifications:

Name: IdleServer1

Virtual processors: 1

Virtual memory: 0.4 GB

Virtual disk size: 5 GB

Virtual network: External Network (keep the default Windows Network DHCP settings)

Creating the virtual machine
We ran the script virt-install webserver.sh:

#!/bin/sh
VM_DISKSTORE=/mnt/lunl
VM_NAME=IdleServerl

mkdir -p $VM_DISKSTORE/$VM NAME/
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virt-install \
--hvm \
--name=$VM NAME \
--vecpus=1 \
--ram=400 \
--file=$VM DISKSTORE/$VM NAME/$VM NAME.dsk \
--file-size=5 \
--nonsparse \
--network=bridge:xenbr0 \
--cdrom=/store/windows/win2003r2sp2 32bit cdl.iso \
--os-type=windows \
--os-variant=win2k3 \
--vnc

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing and configuring the second CSU
To create the VMs needed for eight CSUs, run the following script. For fewer CSUs, change the number after
STOP to the number of CSUs you want to create.

#!/bin/sh
_START=2
_STOP=8
for i in “seq $ START $ STOP; do
for SERVERNAME in MailServer DatabaseServer; do
mkdir /mnt/lun$i/$SERVERNAMESi/
virt-clone --original=${SERVERNAME}1l --name=3${SERVERNAME}$i --
file=/mnt/lun$i/$SERVERNAMES1/$SERVERNAMES] .dsk --
file=/mnt/lun$i/$SERVERNAMESi/$SERVERNAMES{i} data.dsk --nonsparse
done
for SERVERNAME in WebServer JavaServer IdleServer; do
mkdir /mnt/lun$i/$SERVERNAMESi/
virt-clone --original=${SERVERNAME}1l --name=${SERVERNAME}$i -
-file=/mnt/lun$i/S$SERVERNAMESi/$SERVERNAMESi.dsk --nonsparse
done
done

Client installation
In addition to setting up the server under test, we also had to set up the client systems we show in Figure 10. Both
the WebBench and LoadSim workloads require test clients.

Installing the WebBench 5.0 test client systems

To run WebBench, you need two types of test systems. WebBench clients use WebBench software engines to
send HTTP requests to stress the server under test. A single WebBench controller system manages the clients
during as the benchmark runs.

Installing a WebBench 5.0 client
1. Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.
2. Install Windows Server 2003 Service Pack 2 with the default settings.
3. Open the Network Connections window by right-clicking My Network Places and selecting Properties from
the menu.
4. Right-click the network connection, and click Properties.
5. Highlight TCP/IP, and select Properties.
6. Select Use the following IP address, and enter the following information:
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15.

e |IP address 192.168.12.211

e Subnet 255.255.255.0.

Click OK to close the two Properties windows.

Insert the WebBench CD, and open it with Windows Explorer.
Run setup.exe from the location /wb50/client/setup.exe.

. Click Next through all screens, a process that accepts the defaults.
. When the installation completes, copy the WebBench shortcut icon from the open window to the system’s

desktop.

. Close the open windows, and eject the CD.
13.
14.

With WordPad, open the file c:\Windows\system32\drivers\etc\hosts.

After the last text in that file, enter the following additional lines, and click Save.
e 192.168.12.210 controller

e 192.168.12.215 server

Close the hosts file and Windows Explorer.

Installing the WebBench 5.0 controller

We used a single system as both the WebBench 5.0 controller and the vConsolidate controller. We discuss the
specifics of the vConsolidate controller in a later section. We performed the following steps to set up that system
as the WebBench 5.0 controller:

N> R~ON =

RN
o

11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.
Install Windows Server 2003 Service Pack 2 with the default settings.

Insert the WebBench 5.0 CD.

Run /wb50/controlr/setup.exe

Click Next through the installation, which accepts all default options.

With Windows Explorer, open C: \WebBench\Controller\Clientids\client.cdb
Add the client’s IP address to the top of the file. Enter Tab twice, and type the number 1.
Click File>Save, and close the client.cdb file.

Copy vConsolidate.tst file from the vCON\WebBench directory to
C:\WebBench\controller\suites\WebBench.

. Copy the ecommerce cgi template w2k3.tst and ecommerce cgi template w2k3.wl files

from vCON\WebBench directory to C:\WebBench\controller\suites\WebBench
Copy all files from \vCON framework\WebBench daemon in the vConsolidate package to C:\.
Select Start->All Programs—>PC Magazine Benchmarks>WebBench 5.0 Controller.

Click Create/Edit from the Suites drop-down menu.

Browse to the vConsolidate. tst file, and click Open.

Highlight the first Mix, and click Edit.

On the General tab, change Engines per client to 8.

Select the Workload tab.

Change the number of threads to 1.

Click Copy across.

Select the Engines per client and Number of threads check boxes, and click OK.

Click OK to close the suites windows.

Close the WebBench Controller window.

Installing the mail test client
Each mail server VM requires one physical test client system. We performed the following steps to set up each
such system:

arON=

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.

Install Windows Server 2003 Service Pack 2 with the default settings.

Open the Network Connections window by right-clicking My Network Places and selecting Properties.
Right-click the network connection, and click Properties.

Highlight TCP/IP, and select Properties.
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6.

7.
8.
9

10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.

Select Use the following IP address, and enter the following information: IP address 192.168.11.110,

Subnet 255.255.255.0, Preferred DNS server 192.168.11.115 (MailServer1 IP address).
Click OK to close the two Properties windows.

Right-click My Computer, and select Properties.

Click the Computer Name tab.

Click Change.

Select Domain in the member of section, and type the domain vcon . com into the text box.

In the pop-up window, enter administrator for user name, password for password, and click OK.

At the Welcome to the domain screen, click OK.

When the warning that you must restart dialog appears, click OK.
Click OK to close the System Properties window.

Click Yes to the pop-up message to restart the computer.

Log in to the domain using administrator and password.

Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)

Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.
Open LoadSim 2003, and make sure no error messages appeatr.

Copy c:\Program Files\LoadSim\Islog.exe file to a floppy disk or USB thumb drive. You will need this file

during the vConsolidate controller installation.

Configuring LoadSim 2003

14.
15.
16.
17.
18.

19.
20.

21.

22.

Start LoadSim by clicking Start Menu—->All Programs—>Exchange LoadSim->LoadSim 2003.
From the LoadSim menu bar, select Configuration-> Topology Properties.

Click the Servers tab.

In the left pane, click the + beside the name of this server.

In the left pane, select the First Storage Group.

In the right pane, set the number of users to 500.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, enter the password Passwordil, and click OK.

. From the LoadSim menu bar, select Configuration>Test Properties, and click Add.
. Click Customize Tasks.

. Select the Initialization tab.

. Enter the following settings:

e Number of messages in Inbox: 150

Number of messages in Deleted items: 1

Number of new folders: 2

Messages per new folder: 100

Number of Smart Folders: 3

Number of Rules in Inbox: 5

Initialize Free/Busy Information: Leave it unselected
Number of appointments: 25

e Number of contacts: 64

Click OK.

In the Test Properties window, change the run time to 2 hours, and click OK.
From the LoadSim menu bar, choose File>Save As.

Save a backup copy of the simulation file as C:\loadsim.sim.

From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and

Creating DLs tasks complete.
From the LoadSim menu bar, select Run—>Initialize Test.

When a dialog box appears with the question Do you want to initialize Public Folders from this client

machine?, click Yes.

The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task

typically takes about 2 to 3 hours to complete.
From the LoadSim menu bar, select Run->Run Simulation.
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23. The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes a little over 2 hours to complete.

Back up the mail database

Once you’ve set up LoadSim and created its initial mail database, you need to back up that database so you can
have clean copies for each test. For testing we use NetApp Snapshot to create a copy of all VMs. This allows us
to replace the snapshot after each test run and return to the original state.

vConsolidate controller

You use a separate physical system, the controller, to manage the vConsolidate workload. We used a single
section both for this function and as the controller system for the first CSU’s WebBench benchmark. This
controller offers a graphical user interface (GUI) to start and stop the vConsolidate workload. After the workload
finishes, the controller copies the independent benchmark result files from all the VMs and combines their results
into a single file, results.txt. We performed the following steps to set up this vConsolidate controller:

1.  With Windows explore, create a C:\vCON directory.
2. Copy all files from the \WCON_framework\controller directory of the vConsolidate package to c:\\vCON.
3. Copy the Islog.exe file the mail client installation created to c:\vCON.

The vCON directory contains a Profiles sub-directory. The Profiles directory contains four sample profiles,
1CSU.profile, 2CSU.profile, 3CSU.profile, 4CSU.profile, and a blank template, Profile.template. vConsolidate
uses these files to identify the number and name of the VMs a test should include. An example 1CSU.profile
contains the following:

<Profile>

<Name>1 CSU</Name>

<CSUNum>1</CSUNum>

<Servers>

<DB>

<0S>Win</0S>

<Host>DBServerl</Host>

</DB>

<Loadsim>

<Host>192.168.202.110</Host>

</Loadsim>

<Java>

<0S>Win</0S>

<Host>JavaServerl</Host>

</Java>

<WebBench>

<Host>192.168.202.210</Host>

</WebBench>

</Servers>
</Profile>

Running vConsolidate

To run vConsolidate and get consistent results, you must first prepare the VMs with clean copies of the test data.
We outline below the process for getting ready to run the workload. We then explain how to start and stop the
workload. Finally, we detail how to find its results.

Preparing the vConsolidate run
Prior to running vConsolidate we restore the NetApp Snapshot with the Network Appliance NetApp FAS960 filer,
SO we can ensure consistent results.

Verify connectivity and setting profiles
1. Open a command prompt by selecting Start->Run, type cmd, and click OK.
2. Type the following commands at command prompt:
e net use \\loadsim client IP Address\c$
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e net use \\JavaServerl\c$
e net use \\DBServerl\c$
e net use \\WebBench Controller IP Address\c$

3. Verify that the vConsolidate controller can read and write remote files to all VMs with the following
commands:

With Windows Explorer, create an empty file, dummy.txt.

copy dummy.txt \\loadsim client IP Address\c$

copy dummy.txt \\JavaServerl\cs$

copy dummy.txt \\DBServerl\c$
€. copy dummy.txt \\WebBench Controller IP Address\c$

4. Modify the profile file by entering the VM name or IP address appropriate to each VM in the test. For the
one-CSU test, enter four server names or |IP addresses; for the two-CSU test, enter eight.

aoow

Startlng and stopping vConsolidate

Shut down all VMs by selecting Start->Shutdown and then selecting Shutdown from the window.

In the left pane of the Virtual Infrastructure Client window, highlight localhost.localdomain.

Select the Summary tab in the right pane.

Click Reboot under the Commands section.

While the server is rebooting, reboot all clients in the test bed.

After the Red Hat server with XEN has rebooted, login using the Virtual Infrastructure Client, and start all

VMs in the test.

Once the VMs are up, log the LoadSim client(s) into the appropriate domain(s).

Double-click Daemon.exe manually on the following VMs and systems:

o DataServer1

o JavaServeri

e LoadSim client

e WebBench controller

9. Start the WebBench Controller application on the WebBench controller system by selecting Start>All
Programs—->PC Magazine Benchmarks.

10. In the WebBench Controller application, choose the Clients menu, and click Start Log In.

11. Double-click the WebBench 5.0 client shortcut on all the WebBench test client desktops.

12. Once all the client machines are logged into WebBench, click OK.

13. At the Would you like to add a test suite? dialog, click Yes.

14. In the Select a test suite window, choose vConsolidate.tst, and click OK.

15. When the Would you like to start executing the test suites? window appears, do NOT click Yes or No. The
vConsolidate controller application will handle that task that at the start of the test.

16. Double-click c:\vCON\vconsolidate.exe.

17. Select the profile name you want to run.

18. Wait 15 minutes to allow all virtual machines and Red Hat server with XEN to load all processes and
become completely idle.

19. Click Start.

20. The vConsolidate controller software will immediately start the LoadSim application. LoadSim will take
about 60 to 80 seconds to log 500 users onto the Exchange Server. The remaining benchmarks will start
once all the LoadSim users have logged in.

21. After about 30 minutes, the vConsolidate controller application will stop all the other benchmarks and
collect their results.

SorwN

® N

Locating and interpreting the results file
vConsolidate places all results data in the following location:

c:\vCON\vCONMM-dd-hh-mm

where MM is the month, dd is the day, hh is the hour, and mm is the minute of the test. The file result.txt in that
directory summarizes all the results. It contains the following information:
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Java transaction score
Database transaction score
Mail transaction score

Web server throughput
Start and stop times

Figure 11 shows an example results.txt file for a test with one CSU. We have labeled each score with a brief
description. See the Test results section for more information on how we used these individual results to calculate
each server’s overall score on the workload.

B result.txt EI @I E|

File Edit Format View Help

UL
T L ) e

DB T Number=231093— )
RalR e Database Score LoadSim Score
—————————— TEMP. TXT
weighted avg &0 14015 122 215 132 68 <--"score"

—————————— VCONSOLIDATE.RLG

A,4_client, 8,/1706. 959, 6908069, 563, 0,
A,4_client, 8,/1622.183, 6576748, 875, 0,
A,4_client, 8,[1558. 335, 6241389. 500, 0,

11:44:39.921
12:15:44.140

VWebBench Score

Figure 11: Example of vConsolidate results file.

Power measurement procedure

To record each server’s power consumption during each test, we used an Extech Instruments (www.extech.com)
380803 Power Analyzer / Datalogger. We connected the power cord from the server under test to the Power
Analyzer’s output load power outlet. We then plugged the power cord from the Power Analyzer’s input voltage
connection into a power outlet.

We used the Power Analyzer’s Data Acquisition Software (version 2.11) to capture all recordings. We installed the
software on a separate Intel-processor-based PC, which we connected to the Power Analyzer via an RS-232
cable. We captured power consumption at one-second intervals.

To gauge the idle power usage, we recorded the power usage while each server was running the operating
system but otherwise idle. To ensure the server was idle, we allowed the server to boot and power on all virtual
machines. Once the virtual machines had booted, we waited for 15 minutes to allow everything to stabilize. Then
we recorded two minutes of idle power (in watts) at one-second intervals.

To compute the average power usage, we averaged the power usage during the time the server was producing
its peak performance results. We call this time the power measurement interval. See Figure 5 (idle and average
peak power) for the results of these measurements.
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Appendix A — Test system configuration information
Figure 12 provides detailed configuration information about each of the test server systems, which we list in

alphabetical order by processor name.

Servers

AMD Opteron
processor 8360
SE-based server

Intel Xeon
processor X7350-
based server

Intel Xeon
processor X7460-
based server

General processor setup

Number of processor packages 4 4 4
Number of cores per processor package | 4 4 6
Number of hardware threads per core 1 1 1
System Power Management Policy Always On Always on Always on
CPU
Vendor AMD Intel Intel

Intel Xeon Intel Xeon
Name Opteron 8360 SE processor X7350 processor X7460
Stepping 3 B 1
Socket type Socket F (1207) Socket P (478) Socket P (478)
Core frequency (GHz) 2.50 2.93 2.66
Front-side bus frequency (MHz) Iz-i’sggr#::]sport 1,066 1,066

64 KB x 64 KB (per

32 KB + 32 KB (per

32 KB + 32 KB (per

L1 cache
core) core) core)
2 x4 MB (each 4 3x3 MB (each 3
L2 cache 4x512KB (512 KB MBs shar(ed by 2 MB shareEi by 2
per core)
cores) cores)
L3 cache 2MB N/A 16 MB
Platform
Vendor and model number HP DL585 G5 Intel Fox Cove Intel Fox Cove
Motherboard model number PAAXHORSSWI0B | s7000FCaUR S7000FC4UR
Motherboard chipset yagg'p‘ nForce Pro- 11461 103600 Intel ID3600
Motherboard revision number OH 01 01
Intel Intel
BIOS name and version HP AQ7 SFC4UR.868.01.00. | SFC4UR.868.01.00.
(06/27/2008) 0024.06132008225 | 0024.06132008225
3 3
Power Regulator for
ProLiant set to
Static Performance | Enabled Intel Enabled Intel
BIOS settings Mode, enable AMD | Virtualization Virtualization
Virtualization and Technology Technology
No-Execute Page-
Protection
Memory module(s)
ELPIDA Kingston Kingston
Vendor and model number EBE41AE4ACFA- KVR667D2D4F5/4G | KVR667D2D4F5/4G
6E-E | I
PC2-5300 FB- PC2-5300 FB-
Type PC2-5300 DDR2 DDR2 DDR2
Speed 667 MHz 667 MHz 667 MHz
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AMD Opteron Intel Xeon Intel Xeon
Servers processor 8360 processor X7350- processor X7460-
SE-based server based server based server

Speed in the system currently running @ | 667 MHz 667 MHz 667 MHz
T|m|ng/_Latency (tCL-tRCD-iRP- 5.5-5-15 5.5-5-15 5.5-5-15
tRASmin)
RAM Module Size 4 GB 4 GB 4 GB
Number of RAM modules 16 16 16
Chip organization Double-sided Double-sided Double-sided
Total System Memory 64 GB 64 GB 64 GB
Hard drive

Seagate Seagate
Vendor and model number HP DG072BABCE ST9973 201SS ST9973 201SS
Number of disks in system 2 2 2
Size 72 GB 73.4 GB 73.4 GB
Buffer size 16 MB 8 MB 8 MB
RPM 10,000 10,000 10,000
Type SAS SAS SAS

Integrated Intel Integrated Intel
Controller g?ri:toﬁ‘er:ay P400 RAIgD Controller RAIgD Controller

SROMBSASFC SROMBSASFC
Driver 3.6.20-RH1 00.00.03.15-RH1 00.00.03.15-RH1

Operating system

Name

Red Hat Enterprise
Linux 5.2

Red Hat Enterprise
Linux 5.2

Red Hat Enterprise
Linux 5.2

Kernel release

2.6.18-92.el5xen
x86_64

2.6.18-92.el5xen
x86_64

2.6.18-92.el5xen
x86 64

Kernel version

#1 SMP Tue Apr 29
13:16:15 EDT 2008

#1 SMP Tue Apr 29
13:16:15 EDT 2008

#1 SMP Tue Apr 29
13:16:15 EDT 2008

File system ext3 ext3 ext3

Language English English English

Graphics

Vendor and model number ATI ES1000 ATI ES1000 ATI ES1000

Chipset ATI ES1000 ES1000 ES1000
BK-ATI BK-ATI BK-ATI

BIOS version VERO008.005.013.00 | VER008.005.031.00 | VER008.005.031.00
0 0 0

Type Integrated Integrated Integrated

Memory size 32 MB 32 MB 32 MB

Resolution 1,280 x 1,024 1,024 x 768 1,024 x 768

Network card/subsystem
Broadcom

Vendor and model number BCM5706C Intel PRO/1000 EB | Intel PRO/1000 EB
NetXtreme Il GigE

Type Integrated Integrated Integrated

Driver version BCM5706/5708 1000 — 7.3.20-k2- | e1000 — 7.3.20-k2-
1.6.9 NAPI NAPI
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Servers

AMD Opteron
processor 8360
SE-based server

Intel Xeon
processor X7350-
based server

Intel Xeon
processor X7460-
based server

Vendor and model number

Intel PRO/1000 PT

Intel PRO/1000 PT

Intel PRO/1000 PT

Type

PCle

PCle

PCle

Driver version

1000 — 7.3.20-k2-
NAPI

e1000 — 7.3.20-k2-
NAPI

1000 — 7.3.20-k2-
NAPI

A

Optical drive

Vendor and model number HL-DT-ST RW/DVD | Optiarc DVD-ROM Optiarc DVD-ROM
GCC-C10N DDU810A DDU810A

USB ports

Number 4 5 5

Type USB 2.0 USB 2.0 USB 2.0

Power supplies

Total number 2 2 2

Wattage of each 1,300W 1,570W 1,570W

Cooling fans

Total number 6 8 8

Dimensions 5'%5" 4x80mm+4x120 | 4x80 mm+4x120

mm mm
Voltage 12V 12V 12V
Amps 3.3A 4x176 A+4x33 |4x176 A+4x33

A

Figure 12: Detailed configuration information for the three servers.
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Appendix B — Complete test and power results

Figures 13 through 15 show the complete results for all three runs on the two test systems.

AMD Opteron processor 8360 SE

Score | CPU utilization | Idle power | Average power

1CSU

Run 1 3.89 27 501.08 645.94

Run 2 3.82 27 501.98 645.83

Run 3 3.80 27 501.28 645.94
2 CSUs

Run 1 7.21 57 504.09 684.77

Run 2 7.33 57 503.66 685.23

Run 3 7.31 57 504.03 685.25
3 CSUs

Run 1 9.97 90 504.95 711.84

Run 2 9.93 90 506.17 712.62

Run 3 9.95 90 507.38 712.19
4 CSUs

Run 1 11.20 99 507.45 722.01

Run 2 11.23 99 509.25 721.73

Run 3 11.21 100 510.05 721.62
5 CSUs

Run 1 11.95 100 509.67 720.08

Run 2 11.83 100 513.18 724.88

Run 3 11.91 100 513.25 724.82
6 CSUs

Run 1 12.33 100 516.82 722.85

Run 2 12.34 100 516.01 724.86

Run 3 12.36 100 516.63 724.73
7 CSUs

Run 1 12.76 100 517.87 723.76

Run 2 12.85 100 520.38 725.42

Run 3 12.87 100 520.59 725.60
8 CSUs

Run 1 13.10 100 524.68 724.96

Run 2 13.18 100 524.68 725.34

Run 3 13.14 100 524.19 725.45

Figure 13: Complete results for all three runs on the HP DL585 G5 server.
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Intel Xeon processor X7350

Score | CPU utilization | Idle power | Average power

1CSU

Run 1 3.91 27 5565.21 672.35

Run 2 3.99 27 557.80 681.28

Run 3 3.96 27 555.09 674.97
2 CSUs

Run 1 7.40 56 5585.71 735.87

Run 2 7.49 56 556.46 737.28

Run 3 7.40 56 556.40 736.40
3 CSUs

Run 1 11.08 85 555.20 825.41

Run 2 11.10 85 555.38 824.24

Run 3 11.14 86 5585.75 824.71
4 CSUs

Run 1 12.55 99 559.20 827.32

Run 2 12.78 99 556.81 827.25

Run 3 12.55 99 555.28 822.21
5 CSUs

Run 1 13.12 100 560.23 821.42

Run 2 13.11 100 555.97 817.51

Run 3 13.40 100 561.42 826.61
6 CSUs

Run 1 13.65 100 526.97 816.91

Run 2 13.66 100 582.48 823.16

Run 3 12.55 100 559.71 752.33
7CSUs

Run 1 13.79 100 562.91 788.98

Run 2 13.87 100 563.82 816.27

Run 3 14.07 100 560.43 821.61
8 CSUs

Run 1 14.02 100 569.60 824.91

Run 2 14.24 100 564.49 791.06

Run 3 13.86 100 567.05 787.48

Figure 14: Complete results for all three runs on the Intel Xeon processor X7350 server.
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Intel Xeon processor X7460

Score | CPU utilization | Idle power | Average power

1CsSU

Run 1 4.07 18 538.43 633.30

Run 2 4.08 18 539.04 633.90

Run 3 4.02 18 539.98 633.76
2CSUs

Run 1 7.86 36 539.58 687.50

Run 2 7.89 36 540.48 687.94

Run 3 7.81 36 540.02 688.06
3 CSUs

Run 1 11.34 56 537.57 719.30

Run 2 11.33 56 543.46 724.27

Run 3 11.33 56 538.08 718.63
4 CSUs

Run 1 14.70 76 542.14 756.01

Run 2 14.68 76 543.64 757.03

Run 3 14.75 76 538.47 750.96
5 CSUs

Run 1 17.31 93 540.88 768.61

Run 2 17.23 93 538.73 767.44

Run 3 17.29 93 540.63 767.61
6 CSUs

Run 1 18.61 99 543.33 77512

Run 2 18.74 98 548.11 779.65

Run 3 18.68 99 546.01 776.53
7 CSUs

Run 1 19.35 99 549.48 780.38

Run 2 19.50 100 549.79 782.46

Run 3 19.36 100 548.94 782.46
8 CSUs

Run 1 19.68 100 546.18 776.32

Run 2 19.32 100 544.80 775.32

Run 3 19.44 100 544.91 775.32

Figure 15: Complete results for all three runs on the Intel Xeon processor X7460 server.
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